GETIOBUF(9) | Kernel Developer's Manual | GETIOBUF(9) |
struct buf *
getiobuf(struct vnode *vp, bool waitok);
void
putiobuf(struct buf *bp);
Note that the allocated buffer doesn't belong to the buffer cache. To free it, putiobuf() should be used. brelse() should not be used on it.
putiobuf() frees bp, which should be a buffer allocated with getiobuf().
May 6, 2008 | NetBSD 6.1 |