LTSLEEP(9) |
Kernel Developer's Manual |
LTSLEEP(9) |
NAME
ltsleep, tsleep, wakeup — process context sleep and wakeup
SYNOPSIS
#include <sys/proc.h>
int
tsleep(wchan_t ident, pri_t priority, const char *wmesg, int timo);
void
wakeup(wchan_t ident);
DESCRIPTION
The interfaces described in this manual page are obsolete and will be removed from a future version of the system.
The ltsleep() interface has been obsoleted and removed from the system.
Please see the condvar(9), mutex(9), and rwlock(9) manual pages for information on kernel synchronisation primitives.
These functions implement voluntary context switching. tsleep() is used throughout the kernel whenever processing in the current context can not continue for any of the following reasons:
-
The current process needs to await the results of a pending I/O operation.
-
The current process needs resources (e.g., memory) which are temporarily unavailable.
-
The current process wants access to data-structures which are locked by other processes.
The function wakeup() is used to notify sleeping processes of possible changes to the condition that caused them to go to sleep. Typically, an awakened process will -- after it has acquired a context again -- retry the action that blocked its operation to see if the “blocking” condition has cleared.
The tsleep() function takes the following arguments:
-
ident
-
An identifier of the “wait channel” representing the resource for which the current process needs to wait. This typically is the virtual address of some kernel data-structure related to the resource for which the process is contending. The same identifier must be used in a call to wakeup() to get the process going again. ident should not be NULL.
-
priority
-
The process priority to be used when the process is awakened and put on the queue of runnable processes. This mechanism is used to optimize “throughput” of processes executing in kernel mode. If the flag PCATCH is OR'ed into priority the process checks for posted signals before and after sleeping.
-
wmesg
-
A pointer to a character string indicating the reason a process is sleeping. The kernel does not use the string, but makes it available (through the process structure field
p_wmesg
) for user level utilities such as ps(1).
-
timo
-
If non-zero, the process will sleep for at most
timo/hz
seconds. If this amount of time elapses and no wakeup(ident) has occurred, and no signal (if PCATCH was set) was posted, tsleep() will return EWOULDBLOCK.
The wakeup() function will mark all processes which are currently sleeping on the identifier ident as runnable. Eventually, each of the processes will resume execution in the kernel context, causing a return from tsleep(). Note that processes returning from sleep should always re-evaluate the conditions that blocked them, since a call to wakeup() merely signals a possible change to the blocking conditions. For example, when two or more processes are waiting for an exclusive-access lock (see lock(9)), only one of them will succeed in acquiring the lock when it is released. All others will have to go back to sleep and wait for the next opportunity.
RETURN VALUES
tsleep() returns 0 if it returns as a result of a
wakeup(). If a
tsleep() returns as a result of a signal, the return value is
ERESTART if the signal has the
SA_RESTART property (see
sigaction(2)), and
EINTR otherwise. If
tsleep() returns because of a timeout it returns
EWOULDBLOCK.
HISTORY
The sleep/wakeup process synchronization mechanism is very old. It appeared in a very early version of Unix. tsleep() appeared in 4.4BSD. ltsleep() appeared in NetBSD 1.5.