VNSUBR(9) | Kernel Developer's Manual | VNSUBR(9) |
int
vn_bwrite(void *ap);
int
vn_close(struct vnode *vp, int flags, kauth_cred_t cred);
int
vn_default_error(void *v);
int
vn_isunder(struct vnode *dvp, struct vnode *rvp, struct lwp *l);
int
vn_lock(struct vnode *vp, int flags);
void
vn_markexec(struct vnode *vp);
void
vn_marktext(struct vnode *vp);
int
vn_open(struct nameidata *ndp, int fmode, int cmode);
int
vn_rdwr(enum uio_rw rw, struct vnode *vp, void *base, int len, off_t offset, enum uio_seg segflg, int ioflg, kauth_cred_t cred, size_t *aresid, struct lwp *l);
int
vn_readdir(file_t *fp, char *buf, int segflg, u_int count, int *done, struct lwp *l, off_t **cookies, int *ncookies);
int
vn_stat(struct vnode *vp, struct stat *sb);
int
vn_writechk(struct vnode *vp);
If the operation is successful zero is returned, otherwise an appropriate error code is returned. The vnode interlock v_interlock is released on return.
vn_lock() must not be called when the vnode's reference count is zero. Instead, vget(9) should be used.
January 30, 2010 | NetBSD 6.1 |