XCALL(9) | Kernel Developer's Manual | XCALL(9) |
typedef void (*xcfunc_t)(void *, void *);
uint64_t
xc_broadcast(u_int flags, xcfunc_t func, void *arg1, void *arg2);
uint64_t
xc_unicast(u_int flags, xcfunc_t func, void *arg1, void *arg2, struct cpu_info *ci);
void
xc_wait(uint64_t where);
Sometimes it is necessary to modify hardware state that is tied directly to individual CPUs (such as a CPU's local timer), and these updates can not be done remotely by another CPU. The LWP requesting the update may be unable to guarantee that it will be running on the CPU where the update must occur, when the update occurs.
Additionally, it is sometimes necessary to modify per-CPU software state from a remote CPU. Where these update operations are so rare or the access to the per-CPU data so frequent that the cost of using locking or atomic operations to provide coherency is prohibitive, another way must be found.
Cross calls help to solve these types of problem. However, since this facility is heavyweight, it is expected that it will not be used often.
xcall provides a mechanism for making “low priority” cross calls. The function to be executed runs on the remote CPU within a thread context, and not from a software interrupt, so it can ensure that it is not interrupting other code running on the CPU, and so has exclusive access to the CPU. Keep in mind that unless disabled, it may cause a kernel preemption.
xcall also provides a mechanism for making “high priority” cross calls. The function to be executed runs on the remote CPU within a IPL_SOFTCLOCK software interrupt context, possibly interrupting other lower-priority code running on the CPU.
October 24, 2011 | NetBSD 6.1 |